Используйте для вопросов об установщике пакетов Python
2 ответа

Как изменить путь повышения для установки pip3?

Я пытаюсь установить пакет Python с помощью pip3. В какой-то момент во время установки пакет python запускает cmake, который требует boost (libboost-dev) версии 1.58. У меня проблема в том, что у меня установлено два надстройки, один в / usr / local…
07 апр '18 в 10:39
65 ответов

TensorFlow не найден с использованием pip

Я пытаюсь установить TensorFlow с помощью pip: $ pip install tensorflow --user Collecting tensorflow Could not find a version that satisfies the requirement tensorflow (from versions: ) No matching distribution found for tensorflow Что я делаю непра…
11 авг '16 в 12:28
2 ответа

Ошибка установки urllib3

Я использую команду pip install urllib3, трассировка ошибки, которую я получаю, как показано ниже.
08 фев '17 в 12:03
0 ответов

ImportError: невозможно импортировать имя 'main' во время установки AWS CLI на macOS

Каждый раз, когда я следую инструкциям по установке интерфейса командной строки AWS, я получаю следующую ошибку: ImportError: невозможно импортировать имя 'main' Вот вывод из моего терминала (показывая каждый шаг) $ curl -O https://bootstrap.pypa.io…
04 май '18 в 15:26
1 ответ

Ошибка установки pyopenssl с помощью pip

Я пытаюсь установить различные пакеты, используя Python PIP, но я получаю эту ошибку: Файл "/usr/local/lib/python2.7/site-packages/pip-8.1.2-py2.7.egg/pip/_vendor/ cnx.set_tlsext_host_name(server_hostname) AttributeError: '_socketobject' объект не и…
17 окт '16 в 15:06
1 ответ

Невозможно установить сайт распространения

Для прохождения курса мне нужно установить сайт пакета (?) В виртуальную среду Anaconda. Я смог установить другие требования для курса с помощью команды pip install 'somename==version' Тем не менее, когда я побежал pip install 'site==0.0.1' Я получи…
09 фев '18 в 00:17
1 ответ

pip не может установить инструментарий Python (Python 2.7, Windows 7)

Я довольно новичок в Python. Моя ОС - Windows 7, и я использую Python 2.7 (я скачал Python(X, Y)). Теперь pip не может установить набор инструментов igakit и столкнуться со следующей проблемой: $gfortran.lib(backtrace.o) : error LNK2019: unresolved …
09 апр '15 в 15:27
0 ответов

Загрузить разные дистрибутивы колес в PyPI

Я упаковываю проект Python со скомпилированными расширениями, и поэтому мне нужно собрать разные колеса для каждой платформы (Linux и OSX) и версий Python (2.7 и 3.6). Я могу правильно создать каждое колесо с: python setup.py bdist_wheel а затем заг…
08 апр '17 в 20:03
1 ответ

Отменить отключение кеша пипсов

Я случайно побежал с --no-cache-dir вариант. Теперь я запускаю следующее сообщение об ошибке, когда пытаюсь развернуть проект без сервера. The directory '/.cache/pip/http' or its parent directory is not owned by the current user and the cache has be…
17 авг '17 в 19:36
1 ответ

Что случилось с опцией -e для pip?

В документации по пипсу упоминается -e опция pip, и это также используется в некоторых заметках для начинающих разработчиков BuildBot. Тем не менее, у меня есть пип 1.0.1 и работает: pip -e master отчеты Usage: pip COMMAND [OPTIONS] pip: error: no …
01 июн '11 в 18:22
1 ответ

Установка Джанго в виртуален с парамико

Я использую paramiko и создаю некоторые virtualenvs над ssh, например: from paramiko import SSHClient, SSHConfig def ssh_connect(self): # ssh config file config = SSHConfig() config.parse(open(settings.SSH_CONFIG)) o = config.lookup('my_key') # ssh …
27 авг '12 в 20:48
1 ответ

Найти зависимости модуля Pypi перед установкой

Этот вопрос часто задают, но удовлетворительного ответа никогда не бывает. Вот моя ситуация. Я работаю на безопасном объекте. Моя настольная система может подключаться к Интернету, но я не могу устанавливать неутвержденное программное обеспечение, в…
18 янв '18 в 20:28
12 ответов

Есть ли способ перечислить зависимости / требования пипса?

Не пройдя установку, я хочу быстро увидеть все пакеты, которые pip install установил бы.
21 июн '12 в 22:23
0 ответов

Ошибка при импорте sklearn

Я пытаюсь скачать sklearn для моего проекта AI. Я на Windows 10 с PyCharm. Python 3.6.2. Я уже скачал sklearn, который получился просто отлично, но когда я запускаю программу, она говорит, что мне нужно установить scipy, numpy и.base. Ошибка: D:\pyt…
04 авг '17 в 19:39
1 ответ

Установить часть модуля панд

Pandas - довольно громоздкий модуль, поэтому я не хочу устанавливать его в полном объеме. Только те, которые я буду использовать в моих кодах. from pandas import DataFrame from pandas import ExcelWriter from pandas import pivot_table from pandas imp…
20 апр '18 в 13:19
1 ответ

Не удалось выполнить скрипт запуска на экземпляре Google

У меня есть сценарий запуска, который я использую для установки python и импорта файлов из хранилища Google в виртуальную машину. Когда я продолжаю мой скрипт запуска следующим образом: ‘#! /bin/bash gsutil cp gs://bucket/file /homedirectory' Это вы…
1 ответ

`pip install mysql-python` завершается неудачно с" ld: библиотека не найдена для -lssl"

Бег pip install mysql-python не удается с: cc -bundle -undefined dynamic_lookup -arch i386 -arch x86_64 -Wl,-F. build/temp.macosx-10.12-intel-2.7/_mysql.o -L/usr/local/Cellar/mysql/5.7.13/lib -lmysqlclient -lssl -lcrypto -o build/lib.macosx-10.12-in…
18 май '17 в 13:19
0 ответов

OS X pip3 не работает с Brew установить Python3.6.5_1

Я только что сделал новую установку python3 (3.6.5_1) на Mac OS (High Sierra), и pip3 не работает. Я получаю следующую ошибку с pip3: Traceback (most recent call last): File "/usr/local/bin/pip3", line 11, in <module> load_entry_point('pip==10…
20 июн '18 в 16:34
0 ответов

Невозможно настроить pip для пользователя без прав root

Я бегу ниже команды, получая ошибку. python3 /home/user1/get-pip.py --user Traceback (most recent call last): File "/home/user1/get-pip.py", line 20061, in <module> main() File "/home/user1/get-pip.py", line 194, in main bootstrap(tmpdir=tmpdi…
06 апр '18 в 04:00
0 ответов

Pip3 выдает ошибку "Не найдено подходящего распределения для..."

У меня есть файл reqs.txt, содержащий множество требований к Python, которые необходимо установить на второй компьютер. Файл выглядит так: alabaster==0.7.9 anaconda-client==1.6.0 anaconda-navigator==1.4.3 astroid==1.4.9 astropy==1.3 Babel==2.3.4 bac…
29 июн '17 в 14:54