Могу ли я установить последнюю версию phpMyAdmin и использовать ее с WampServer?

У меня есть WampServer 2.0 с phpMyAdmin 3.2.0.1. Последняя версия phpMyAdmin: 3.3.8.1.

Могу ли я загрузить последнюю версию phpMyAdmin и использовать ее с WampServer?

Я хочу сделать это потому, что в phpMyAdmin 3.2.0.1 линии связи между таблицами не отображаются в Internet Explorer 8 (даже если они появляются в Firefox и Chrome). Я хочу посмотреть, исправлена ​​ли последняя версия.

Благодарю.

ОБНОВЛЕНИЕ: линии отображаются в представлении совместимости.

4 ответа

Решение

Могу ли я загрузить последнюю версию phpMyAdmin и использовать ее с WampServer?

Конечно. Вы даже можете установить его в отдельном каталоге и указать в той же базе данных, что и в другой версии.

Следуй этим шагам

  1. Загрузите последнюю версию PHPMyAdmin по адресу http://www.phpmyadmin.net/home_page/downloads.php. Примечание. Если вы используете PHP версии 5.3, вам следует загрузить последнюю версию PHPMyAdmin 3.x, в противном случае загрузить последнюю версию PHPMyAdmin 2.x

  2. Идти к C:\wamp\apps\phpmyadmin3.2.0.1\ и скопируйте файл config.inc.php в безопасное место. Вы делаете это в случае, если у вас установлена ​​защищенная паролем установка MySQL или определенные параметры MySQL, которые вы хотите сохранить.

  3. Создать папки в C:\wamp\apps\phpmyadmin4.2.5\

  4. Скопируйте содержимое разархивированной папки (не папки) в C:\wamp\apps\phpmyadmin4.2.5\ каталог.

  5. Затем скопируйте обратно файл config.inc.php в C:\wamp\apps\phpmyadmin4.2.5\, который вы скопировали ранее.

  6. Идти к C:\wamp\alias\phpmyadmin.conf, Изменить следующее:

    Alias /phpmyadmin "c:/wamp/apps/phpMyAdmin-3.2.0.1/"
    
    <Directory "c:/wamp/apps/phpMyAdmin-3.2.0.1/">
         Options Indexes FollowSymLinks MultiViews
         AllowOverride all
         Order Deny,Allow
         Deny from all
         Allow from 127.0.0.1
     </Directory>
    

    чтобы:

    Alias /phpmyadmin "c:/wamp/apps/phpmyadmin4.2.5/"
    
    <Directory "c:/wamp/apps/phpmyadmin4.2.5/">
        Options Indexes FollowSymLinks MultiViews
        AllowOverride all
        Order Deny,Allow
        Deny from all
        Allow from 127.0.0.1
    </Directory>
    
  7. Перезапустите wamp и запустите PHPMyAdmin в вашем браузере и посмотрите, работает ли он.

PHPMyAdmin был обновлен

Абсолютно!

Я подробно рассказал о том, как обновить phpMyAdmin в WAMP с помощью серии снимков экрана в блоге. Ниже приведены основные шаги.

  1. Загрузите самую последнюю стабильную версию phpMyAdmin.
  2. Извлеките содержимое загрузки в каталог приложений внутри корня WAMP, обычно c:/wamp/apps,
  3. Скопируйте config.inc.php файл конфигурации от текущей версии phpMyAdmin до новой версии.
  4. Обновите phpmyadmin.conf Файл конфигурации, расположенный в каталоге псевдонимов, обычно c:/wamp/alias, Укажите Alias а также <Directory> пути к вашему новому каталогу phpMyAdmin.
  5. Обновите wampmanager.conf Файл конфигурации находится в корневом каталоге WAMP.
  6. И последнее, но не менее важное: перезапустите все службы в WAMP (при условии, что WAMP запущен) и войдите в свой обновленный phpMyAdmin.

Вы можете легко обновить
-> просто откройте ссылку, загрузите нужную версию и запустите домашнюю страницу Wampserver.

Другие вопросы по тегам