Я не могу получить доступ к http://localhost/phpmyadmin/

Проблема:

Я не могу получить доступ localhost/phpmyadmin/

прежде чем я смогу получить доступ localhost/phpmyadmin/ но сегодня, когда я пытаюсь получить доступ к этой странице, я получил странную страницу

также я могу получить доступ localhost/xampp/ без каких-либо проблем

Вопрос:

Как я могу решить эту проблему?

20 ответов

Что вам нужно сделать, это добавить phpmyadmin в конфигурацию apache:

sudo nano /etc/apache2/apache2.conf

Добавьте конфигурацию phpmyadmin в файл:

Include /etc/phpmyadmin/apache.conf

затем перезапустите apache:

sudo service apache2 restart

В Windows, я думаю, вы можете просто перейти к файлу конфигурации apache2 и включить файл конфигурации phpmyadmin, как показано выше, а затем перезапустить apache

Более чистый способ - создать новый файл конфигурации:

/etc/apache2/conf-available/phpmyadmin.conf

и напишите в нем следующее:

Include /etc/phpmyadmin/apache.conf

затем мягкую ссылку на файл в каталог /etc/apache2/conf-enabled:

sudo ln -s /etc/apache2/conf-available/phpmyadmin.conf /etc/apache2/conf-enabled

Вы должны использовать localhost:portnumber/phpmyadminЗдесь Portnumber это номер, который вы установили для своего веб-сервера, или если вы не установили его до сих пор, он по умолчанию - 80,

Убедитесь, что и веб-сервер apache, и сервер MySQL работают. У меня была такая же ошибка, потому что я забыл запустить свой веб-сервер.

Когда вы запускаете Xampp, проверьте номер порта apache. например: если отображается порт 80, введите

http://localhost:80/phpmyadmin/

После этого он будет отображаться автоматически

HTTP: // локальный / PHPMyAdmin /

Обычно это происходит, когда порт по умолчанию для localhost используется другим приложением (например, apache tomcat). Простое решение - остановить приложение и просто перейти к localhost / phpmyadmin.

В моем случае это сработало после остановки Apache Tomcat.

sudo apt-get -y --reinstall install phpmyadmin;
sudo service apache2 restart;

Надеюсь это поможет.

Иногда это чувствительно к регистру. Вы пытались идти в http://localhost/phpMyAdmin?

Я использую Linux Mint: после установки LAMP вместе с PhpMyAdmin я связал оба файла конфигурации Apache и PhpMyAdmin. Это добилось цели. Ниже приведены команды.

sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf.d/phpmyadmin.conf

sudo /etc/init.d/apache2 reload

Судя по вашему выводу, один из ваших плагинов работает с phpmyadmin. Попробуйте отключить все плагины, чтобы увидеть, работает ли это.

Если это так, включите их один за другим и проверьте еще раз, чтобы найти проблемный.

Запустите сервер Apache, запишите номер порта (например, 8081). Откройте браузер и введите localhost:8081(или номер порта apache).

Решая ту же проблему в Ubuntu 14.04, я использую код:

    sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-enabled/phpmyadmin.conf
    sudo /etc/init.d/apache2 reload

это связано с тем, что начиная с Ubuntu 13 Apache загружает файлы конфигурации из каталога /etc/apache2/conf-enabled.

Документация по Ubuntu

Более простой способ включить конфигурацию phpmyadmin в apache2 - создать новый файл конфигурации:

sudo nano /etc/apache2/conf-enabled/phpmyadmin.conf

и напишите в нем:

Include /etc/phpmyadmin/apache.conf

Или может быть, что Skype работает на том же порту (по умолчанию).

Отключите Skype или настройте Skype для использования другого порта

Я также столкнулся с той же проблемой. я поработал над этим и обнаружил, что это просто потому, что я по ошибке переместил свою папку "phpmyadmin" в какую-то папку внутри Xampp. Пройдите через все остальные папки, которые находятся внутри основной папки "XAMPP". Затем, если вы найдете "phpmyadmin" в другой папке, отличной от "xampp", переместите его обратно в основную папку "XAmpp" и обновите страницу.:)

Судя по выводу изображения, которое вы связали в одном из ваших комментариев:

http://imageshack.us/photo/my-images/638/erroruh.png/

... может быть, вы случайно скачали какую-то форму веб-сайта, откуда вы думали, что скачиваете phpMyAdmin. Текст содержит ссылки на "Dropbox", что заставляет меня думать, что отображение информации никак не связано с phpmyadmin.

Попробуйте переустановить и посмотрите, поможет ли это...

http://www.phpmyadmin.net/

Просто измените - $cfg['Servers'][$i]['host'] = 'localhost'; в config.inc.ph. то есть с существующего на локальный, если вы установили его локально

http://localhost:80/phpmyadmin/ 

или если вы изменили порт с httpd.conf, напишите номер порта вместо 80.

Foun После прочтения каждой строки, возвращаемой в phpinfo() в браузере, я заметил, что "путь к файлу конфигурации" был скомпилирован как C:\WINDOWS.

Переместил туда php.ini, перезапустил сервер (Apache) и вуаля! mysql и phpmyadmin работает! работает.

Переместить / скопировать php.ini в C:/WINDOWS.

Надеюсь это поможет!

У меня такая же проблема. Не удалось получить доступ http://localhost/joomla ни.
и я не совсем понял другие ответы.
Простое решение для меня:

  1. остановите все действия в xampp (у меня были запущены apache и mysql. apache на порту 80 и 7000 что-то)
  2. выйти из Firefox
  3. перезапустите действия (apache и mysql)
  4. перезапустите Firefox.
  5. открыть http://localhost/phpmyadmin (или же http://localhost/joomla - как бы то ни было)
  6. вуаля!

Теперь apache работает на портах 80 и 443 и mysql на 3306.

Убедитесь, что у вас все еще есть phpMyAdmin, может быть, вы удалили его в своей папке htdocs?

Получить последнюю версию: http://www.phpmyadmin.net/home_page/downloads.php

Разархивируйте и поместите phpMyAdmin (переименуйте папку, если она имеет номера версий) в вашу папку htdocs.

Убедитесь, что Skype отключен, так как он иногда запускается на том же порту, что и ваша установка XAMPP... Я не уверен, почему, но apache, установленный через xampp на некоторых компьютерах с Windows 7, видел, что apache не запускается, если скайп включен после 10 лет IT работа.

Поэтому убедитесь, что apache запущен, mysql запущен и нажмите:

локальный / PhpMyAdmin

Вы должны получить какую-то подсказку об установке. Шаг через это вы узнаете много по пути. Но в основном это один файл конфигурации, который нуждается в некоторых настройках.

Что вам нужно сделать, так это добавить phpmyadmin в конфигурацию apache:⠀⠀⠀⠀⠀⠀⠀

sudo nano /etc/apache2/apache2.conf

Добавьте в файл конфигурацию phpmyadmin:

Include /etc/phpmyadmin/apache.conf

Затем перезапустите apache:

sudo service apache2 restart

В ubuntu 18.0.1, я думаю, вы можете просто перейти к файлу конфигурации apache2 и включить файл конфигурации phpmyadmin, как показано выше, а затем перезапустить apache

http://127.0.0.1/phpmyadmin/

Другие вопросы по тегам